Apple has begun dropping compatibility for PowerPC processors. It all starts with some of the featres in iLife ’09.

System requirements found on the Apple Store website say, in fine print, “GarageBand Learn to Play requires an Intel-based Mac with a dual-core processor or better.”

and continue with the possibility of Snow Leopard not being compatible with PowerPC processors.

Official documentation from Apple gives clues that PowerPC Macs very well may be left out completely when Mac OS X 10.6 Snow Leopard is released sometime during the first half of this year. Developer copies distributed at WWDC last year included a requirements PDF that listed “an Intel processor” as the minimum necessary to run the software.

AppleInsider | iLife ’09 not fully compatible with PowerPC Macs.